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LEADTOOLS Screen Capture Application Help

Introduction

 XE "Introduction " \* MERGEFORMAT Introduction

LEADTOOLS Screen Capture Application is a powerful, yet easy-to-use application that allows you to capture, open, and save images to many different file formats. It also allows you to compress images, in order to reduce file size.

Using LEADTOOLS Screen Capture Application, you can capture nearly any imagean entire screen, an active window, a selected menu, a window or menu under the cursor, a selected window object (button, tool bar, icon, or client area), a selected area (rectangle, ellipse, triangle, polygon or freehand), wallpaper, the mouse pointereven a resource stored in an EXE or DLL file. You can also assign hotkeys, set up multiple captures, and set up capture time intervals.

Once you have captured an image, you can specify compression parameters and save it to any of over 150 file types.

Supported Environments:

The LEADTOOLS Screen Capture Application and  LEADTOOLS Screen Capture Toolbar come  in WIN32 and x64 editions that can run under the following operating systems:
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Microsoft Windows 98
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Microsoft Windows ME
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Microsoft Windows 2000
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Microsoft Windows XP (32 and 64 bit)
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Microsoft Windows 2003 (32 and 64 bit)
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Microsoft Windows Vista (32 and 64 bit)

For more information on LEADTOOLS Screen Capture Application features, refer to:

Summary of All Supported Image File Formats
Compression Using LEAD and JPEG Formats
Compression Quality Factors
Capture Menu
Capture Options Dialog
 XE "References " \* MERGEFORMAT 

 XE "Documentation " \* MERGEFORMAT ePrint Documentation

LEADTOOLS is committed to fully documenting its products. Please feel free to contact us with any errors or omissions.

Microsoft HTML Help 1.0

Microsoft HTML Help 1.0 (.chm) files for all ePrint components and platforms are installed with your product. Help files are found on the installation path in the \Help\ subdirectory (for example, C:\Program Files\LEAD Technologies, Inc\LEADTOOLS ePrint 5\Help\).

WebHelp

WebHelp that contain the most-current version of LEADTOOLS documentation is available online at:

http://www.eprintdriver.com/help-files.html
Printable reference manuals

Printable reference manuals that contain the same information as online help can be downloaded from our website at:

http://www.eprintdriver.com/help/v5.0/Printable_Documentation/.

For more information:

Specific help references for each ePrint component and platform are available as follows:

	* Launch Help File
	Web Help (Online)

	
	ePrint 5 Activation

	
	ePrint 5 Professional

	
	ePrint 5 API SDK

	
	ePrint 5 COM SDK

	
	ePrint Terminal Server edition

	
	LEADTOOLS Screen Capture Application

	
	LEADTOOLS Screen Capture Toolbar


* Availability depends on specific installed components.
See Also:

Technical Support
 XE "Topic Selection " \* MERGEFORMAT 

 XE "Technical Support " \* MERGEFORMAT 

 XE "Support " \* MERGEFORMAT 

 XE "Products " \* MERGEFORMAT Technical Support

As a registered user, free technical support is available. You must register your software to receive any technical support. You can contact us through the following methods:

	E-mail:
	eprintsupport@leadtools.com

	FAX: 
	(704) 372-8161

	Home page: 
	http://www.eprintdriver.com

	Forum:
	http://support.leadtools.com/SupportPortal/cs/forums/26/ShowForum.aspx

	FAQ:
	http://www.eprintdriver.com/faq.html

	FTP:
	ftp.leadtools.com


You can also contact LEAD by mail at:

LEAD Technologies, Inc.
Attn: Technical Support
Suite 400
1201 Greenwood Cliff,
Charlotte, NC 28204

Before contacting technical support, please look in the online documentation and the example programs for an answer to your question.

 XE "How to capture images with LEADTOOLS Screen Capture Application " \* MERGEFORMAT How to capture images with LEADTOOLS Screen Capture Application

	1.
	From the menu, select Options -> Capture Options. The Capture Options dialog will open.

	2.
	In the Capture Options dialog, click the Hotkey field box, then press the key you wish to use for capture, then click OK.
For example: press <F11>.
Note: Unless you wish to change this hotkey, you only need to do this the first time you use the application. You can change this hotkey any time.
Note: If you already use the  LEADTOOLS Screen Capture Toolbar, you cannot set this hot key if the Start Capture button is enabled. You must first click Stop Capture on the toolbar.

	3.
	If desired, from the menu select Options -> Show Thumbnails button to open the Captured Images window. You can close and re-open this window whenever needed to view your captured images.

	4.
	From the menu, select, Capture , then select a capture type.
For example: select "Menu Under Cursor."

	5.
	If desired, from the menu, select Options -> Capture Area Options. The Capture Area Options Dialog will open. Change any settings as needed.

	6.
	If desired, from the menu, select Options -> Capture Object Options. The Capture Object Options Dialog will open. Change any settings as needed.

	7.
	Open, close, display, select, or otherwise navigate to what you wish to capture.

For example: roll your cursor over a menu item, display a sub-menu, and roll your cursor over an option.

	8.
	Press your designated hotkey (selected in steps 12 above).
For example: press <F11>.

	9.
	Repeat steps 89 as many times as desired. Thumbnails of your captured images will appear in the Captured Images window (step 3, above). The full-sized images will appear as separate files in the main window.

	10.
	In the Captured Images window, right click any thumbnail, then from the menu select Save
Note: you can also select multiple images, then right-click and select Export All

	
	or

	
	In the main window, select an image, then from the menu, select File -> Save.

	11.
	Select desired options in the Save Changes dialog, then click Save.

	12.
	When finished, from the menu select Capture -> Stop Capture. This will "release" your capture hotkey. To begin more captures, return to step 4.


 XE "Wavelet CMP compression " \* MERGEFORMAT 

 XE "Compression " \* MERGEFORMAT 

 XE "CMW file format " \* MERGEFORMAT 

 XE "CMP compression " \* MERGEFORMAT Compression Using LEAD and JPEG Formats

Once you have captured an image, its file size can range from 100 kilobytes to more than 200 megabytes. Compressing color and grayscale graphic images:
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Dramatically decreases the storage requirements
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Improves the input and output speed within a system
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Improves the transmission speed over networks or phone lines

Using LEADTOOLS Screen Capture Application, you can control the amount of compression applied to your images, allowing image quality to match the needs of your application. The Compression Quality Factorssetting allows you to specify how you wish to manage the trade-off between maximum quality and minimum file size.

JPEG Compliant

LEADTOOLS API is fully JPEG compliant. Any file using compression that is compliant with the JPEG Interchange File Format can be viewed and converted. (Images that are not fully compliant with the JPEG specification may be displayed upside-down).

4-bit and 1-bit Images

JPEG and LEAD CMP compression are intended for use with high-resolution images. They are impractical for use with 4-bit or 1-bit images. For these images, use CCITT, LEAD 1-bit, RLE, LZW, or ZIPLib compression methods.

8–24-bit Images

Created by LEAD Technologies, Inc., the LEAD CMP compression format delivers a much smaller file size and better image quality than other compression techniques, including JPEG. By incorporating LEAD and JPEG image compression, files can be reduced to 200 times smaller than their original size, allowing you to develop applications that would be impractical otherwise.

Normally, to compress an 8-bit color image, internal JPEG compression functions must first convert the 8-bit data into raw RGB 24-bit format before compressing it as a color image. LEAD's CMP file format allows for decompression of a 24-bit medium at 24-bit color, or of an 8-bit medium at 8-bit color, without sacrificing image quality. This eliminates the need to save both an 8-bit file and a 24-bit file, or to convert all images to 8 bits in order to support low-end users. The result is a single file, of much smaller file size, that can be viewed on a 24-bit video card at 24-bit true color, as well as on an 8-bit VGA card at 256 colors. Thus, compressing the original 24-bit image actually results in a smaller file size and higher quality than compressing an optimized 8-bit color image.

LEADTOOLS functions compress 8-bit grayscale as 8-bit grayscale JPEG or CMP images. LEAD's CMW file format uses Wavelet CMP compression. Currently, 24-bit color images and 8, 12 and 16-bit grayscale images are supported in this format.

For more information on LEAD and JPEG compression formats, as well as other supported formats, see:

Summary of All Supported Image File Formats 
 XE "Compression Quality Factors " \* MERGEFORMAT 

 XE "Compression " \* MERGEFORMAT Compression Quality Factors

You can specify a quality factor when saving an image file to LEAD, JFIF, LEAD2JFIF, LEAD2JFIF, JTIF, LEAD1JTIF, and LEAD2JTIF formats. The quality factor (Q factor) is a number that determines the degree of loss in the compression process. You can set a value from 2 to 255, with 2 representing the highest quality and 255 representing the most compression.

For JFIF and JTIF compression only, you can also use a factor of 0 to produce lossless JPEG files

For LEAD CMP compression only, you can also use one of the following enhanced options:

	Q Factor
	Predefined options for LEAD only

	PQ1
	Perfect quality 1

This option compresses all colors of a 24-bit file and maintains the quality of the original image at a smaller file size. As the name suggests, there is no visual loss of color at this setting.

	PQ2
	Perfect quality 2

This will produce a smaller file size than PQ1 while maintaining similar quality.

	QFS
	Quality far more important than size

This option removes colors not noticed by the human eye. Most viewers cannot tell the difference between an image compressed at this level and the original image.

	QMS
	Quality more important than size

While more colors are removed, most of them are colors or shades that are close to one another. The compressed image will appear very much like the original image. It will take some study to see the difference.

	QS
	Quality and size equally important

This option provides the highest compression while maintaining good image quality. Try this option first, then move up or down the list accordingly to obtain acceptable compression size and image quality.

	SQS
	Size more important that quality (sharp)

This option is recommended for images that have sharp edges. For example, an image that has a text overlay or an image with many straight lines. While it creates a larger file than the next option, it retains better edges.

	SQT
	Size more important than quality (less tiling)

This option produces less tiling in the image than the previous options. However, it may distort text or straight lines. It is a good option for image database applications.

	MCQ
	Maximum compression keeping quality

This option provides maximum compression while maintaining as high as possible image quality.

	MC
	Maximum compression

This option gives maximum compression. It is equivalent to a Q factor of 255.


Copyright Notice

 XE "Copyright notice " \* MERGEFORMAT Copyright Notices

©Copyright LEAD Technologies, Inc. 1991-2007. ALL RIGHTS RESERVED

Portions of the PCDLIB32.DLL, PCDLIB.DLL, LFFPX7.DLL, LFKODAK.DLL, EKFPIXJPEG140.DLL, PDC_SDK.DLL, PROFIRE.DLL, DC120V154_32.DLL, LFDCR14N.DLL, DCSPROBACK.DLL, DCSPRO3SLR.DLL, LFDCS14N.DLL, and LFKDC14N.DLL files contain material that is ©Copyright Eastman Kodak Company, 1996-2001. This software is based in part on the work of the Independent JPEG Group.

Portions of the LFCRW14N.DLL, LTCMP14.DLL, CDSDK.reg, CDSDK.dll, CDRAPCLS.dll, czs_ui.dll, deimg.dll, deImg010.dll, deImg110.dll, deImg153.dll, deimg301.dll, deimg401.dll, deImg404.dll, deimg602.dll, Deimg603.dll, DeImgd60.dll, pscAdimg.dll, pscCllct.dll, pscCStUI.dll, pscDcd.dll, pscDevUI.dll, pscDvlp.dll, Pscl2STI.dll, pscll.dll, pscParse.dll, pscSetup.dll, psdkdll.dll, psdkReg.dll, psParse.dll. file contain material that is © Canon, Inc. 2002 

Portions of the LFFPX7.DLL and LFKODAK.DLL files contain material that is ©Copyright Hewlett Packard, 1996.

Portions of the OCR/ICR/OMR Features and the help file for the OCR/ICR/OMR Features are ©Copyright Scansoft, Inc. 1995-2003. ALL RIGHTS RESERVED

Portions of the LEADTOOLS PDF Plug in and the LEADTOOLS Vector Imaging Pro are ©Copyright 1996, 2000 Artifex Software Inc. All rights reserved.

File filters for decoding MrSID ® and DjVu ® formats are provided under a license from Lizardtech, Inc.

The "FlashPix" format uses Microsoft's OLE structured storage.

Portions of the DICOM help files in Medical Imaging product line are reprinted with permission from the National Electrical Manufacturers Association ©Copyright 1998 by the National Electrical Manufacturers Association. All rights including translation into other languages, reserved under the Universal Copyright Convention, the Berne Convention or the Protection of Literacy and Artistic Works, and the International and Pan American Copyright Conventions.

Portions of LEADTOOLS Data Security Add On contain software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/), including cryptographic software written by Eric Young (eay@cryptsoft.com) and by Tim Hudson (tjh@cryptsoft.com). Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved. Copyright Tim Hudson 1995-1998 (tjh@cryptsoft.com) All rights reserved.

Portions of LEADTOOLS Data Security Add On contain software based on the MD5 Message Digest Algorithm developed by RSA Data Security, Inc.. Copyright (c) 1991-92 RSA Data Security, Inc. All Rights Reserved.

Portions hereof licensed under US patent 5,327,254 and foreign counterparts.

Trademarks

LEAD® and LEADTOOLS® are registered trademarks of LEAD Technologies, Inc. 
Microsoft, Windows, Windows NT, Visual Basic, Visual FoxPro, and Microsoft Access are either trademarks or registered trademarks of the Microsoft Corporation. 
OS/2® is a registered trademark of International Business Machines Corporation.

ISIS® is a registered trademark of Pixel Translations, Inc.

TextBridge®OCR is a registered trademark of Scansoft, Inc.

ScanAhead™ is a trademark of Pixel Translations, Inc.

FlashPix™ is a trademark of Eastman Kodak Company.

All other brand or product names used in this online help are trademarks of their respective holders.

Address and Contact Information

LEAD Technologies, Inc.
Suite 400
1201 Greenwood Cliff
Charlotte, NC 28204

FAX: (704) 372-8161
E-mail: sales@leadtools.com
Technical support: eprintsupport@leadtools.com 
Home page: http://www.eprintdriver.com 
File Formats

 XE "True color " \* MERGEFORMAT 

 XE "Raster image formats " \* MERGEFORMAT 

 XE "High color " \* MERGEFORMAT 

 XE "Grayscale " \* MERGEFORMAT 

 XE "Formats " \* MERGEFORMAT 

 XE "File formats " \* MERGEFORMAT 

 XE "Black and white images " \* MERGEFORMAT 

 XE "Bitonal images " \* MERGEFORMAT 

 XE "8-bit images " \* MERGEFORMAT 

 XE "4-bit images " \* MERGEFORMAT 

 XE "32K color images " \* MERGEFORMAT 

 XE "32-bit images " \* MERGEFORMAT 

 XE "256-color images " \* MERGEFORMAT 

 XE "24-bit images " \* MERGEFORMAT 

 XE "2-color images " \* MERGEFORMAT 

 XE "16M color images " \* MERGEFORMAT 

 XE "16-color images " \* MERGEFORMAT 

 XE "16-bit images " \* MERGEFORMAT 

 XE "1-bit images " \* MERGEFORMAT Summary of All Supported Image File Formats
LEADTOOLS Screen Capture Application supports over 140 file formats, including:
Color and Grayscale
AFP Format
BMP Formats
Computer Graphics Metafile (CGM)
DGN (DGN)
DICOM Format (DIC)
Dr. Halo (CUT)
DRaWing (DRW)
Drawing Interchange Format (DXF)
DWF Format (DWF)
DWG Format (DWG)
Encapsulated PostScript (EPS)
ESRI Shape (SHP) Format
Exif Formats (TIFF and JPG)
Flic Animation (FLC)
Gerber Format (GBR)
GIF and TIFF with LZW Compression
Icons and Cursors (ICO and CUR)
Interchange File Formats (IFF)
JBIG Format (JBG)
JPEG and LEAD Compressed (JPG, J2K, JP2, CMP, and CMW)
Kodak Formats (PCD and FPX)
Macintosh Pict Format (PCT)
Microsoft Windows Clipboard (CLP)
PCX Formats (PCX and DCX)
PhotoShop 3.0 Format (PSD)
PLT (PLT)
Portable Bitmap Utilities (PBM)
Portable Document Format (PDF) 

Portable Network Graphics Format (PNG)
Printer Command Language Format (PCL)
PTOCA Format (PTOCA)
Scitex Continuous Tone Format
Silicon Graphics Image Format (SGI)
SUN Raster Format (RAS)
TIFF Without LZW Compression
Truevision TARGA Format (TGA)
Windows Animated Cursor (ANI)
Windows Metafile Formats (WMF and EMF)
Wireless Bitmap Format (WBMP)
WordPerfect Format (WPG)
X WindowDump (XWD)
XPicMap (XPM)
Bitonal (1-Bit)
Image Object Content Architecture (IOCA/MODCA)
Intergraph Format (ITG)
LEAD 1-Bit Format (CMP)
Miscellaneous 1-Bit Formats (MAC, IMG, and MSP)
SMP Format (SMP)
TIFF CCITT and Other FAX Formats
XBitMap Format (XBM)
 XE "TIFF file format " \* MERGEFORMAT 

 XE "Multipage files " \* MERGEFORMAT 

 XE "GIF file format " \* MERGEFORMAT 

 XE "FlashPix file format " \* MERGEFORMAT 

 XE "DCX file format " \* MERGEFORMAT 

 XE "Animated Gif " \* MERGEFORMAT Multipage File Formats
LEADTOOLS supports the following multipage file formats:
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Animated Gif
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CALS3
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DCX
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FlashPix
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IOCA/MODCA
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Tiff(MPT)
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Icons and Cursors (ICO and CUR)
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Windows Animated Cursor (ANI)
[image: image18.jpg]


Interchange File Formats (IFF)
Color and Grayscale

 XE "AFP (AFP) " \* MERGEFORMAT 

 XE "AFP " \* MERGEFORMAT AFP Format (AFP)

The AFP format is part of IBM's document imaging system. It is a raster format, created to add enhanced formatting and indexing capabilities to documents for print applications in finance, retail, insurance and other industries. LEAD provides support for the user to open MODCA/PTOCA or AFP/PTOCA documents.

The default extension used by this format is: AFP.

This format is used by the IBM plug in.

This file format does not support stamps or Lossless JPEG compression, but it does support multi-page files.

For AFP files, you can read the following bits per pixel: 24.

Currently, LEAD does not save AFP files, but these files can be saved to IOCA.

 XE "ANI " \* MERGEFORMAT Windows Animated Cursor (ANI)

ANI is an animated cursor (animated mouse pointer). This file format is used for reading and storing Windows Animated Cursors. The LEADTOOLS filter does not support transparency information within these files.

Multipage ANI files will have an icon on each page.

For ANI files, you can read and write the following bits per pixel: 1, 4, 8, 24.

 XE "Windows Bitmap " \* MERGEFORMAT 

 XE "OS/2 file format " \* MERGEFORMAT 

 XE "BMP file format " \* MERGEFORMAT BMP Formats

LEADTOOLS reads and writes the following BMP formats:
[image: image19.jpg]


Windows Bitmap (BMP). This is a file format created by Microsoft. Some BMP images are compressed with an RLE-type compression.
You can read and write the following bits per pixel, without RLE compression: 1, 4, 8, 16, 24, 32.
You can read and write the following bits per pixel, with RLE compression: 4, 8.
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OS/2 Bitmap (OS/2 BMP). These are files created on an OS/2 operating system. LEADTOOLS supports both 1.x and 2.x formats.
You can read and write the following bits per pixel, without RLE compression: 1, 4, 8, 24.
You can read (but not write) the following bits per pixel, with RLE compression: 4, 8.
 XE "CGM " \* MERGEFORMAT Computer Graphics Metafile (CGM)

Computer Graphics Metafile is a format used for the exchange of vector and bitmap data. LEADTOOLS supports versions 1, 2 and 3 of CGM, as well as the Binary data-encoding format of CGM. 

For CGM files, you can read the following bits per pixel: 24.

 XE "CLP " \* MERGEFORMAT Microsoft Windows Clipboard (CLP)

CLP stands for Microsoft Windows Clipboard. This file format is used to store the contents of the clipboard to disk. The clipboard is an area of memory shared by the Windows operating system, and it is a simple mechanism for exchanging data between applications.

For CLP files, you can read and write the following bits per pixel: 1, 4, 8, 24.

 XE "CUT " \* MERGEFORMAT Dr Halo (CUT)

Dr. Halo files are device-independent images. The image is stored in one file (.CUT) and the palette is stored in a separate file (PAL). If the image has no corresponding .PAL file, it is considered a grayscale image.
For CUT files, you can read and write the following bits per pixel: 8.
 XE "DGN " \* MERGEFORMAT DGN (DGN)

DGN (also RDL) is a file format common to Intergraph's MicroStation and Interactive Graphics Design System (IGDS) CAD applications running on Intergraph workstations and PCs. 

LEADTOOLS supports DGN versions 1, 2 and 3.
For DGN files, you can read the following bits per pixel: 24.

 XE "DICOM file format " \* MERGEFORMAT DICOM Format (DIC)

DICOM (DIC) files are commonly used in medical images. LEADTOOLS reads a broad range of DICOM formats, converting them to LEAD-supported bits-per-pixel as necessary. LEADTOOLS writes DICOM files in the LEAD-supported bits-per-pixel. DICOM files can contain many comment fields of various types.
You can read DICOM files as follows:
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Grayscale files in the 1- to 16-bit range are loaded as they are in the original file.
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Palettized color files in the 1- to 16-bit range are converted to 8-bit palettized or 24-bit unpalettized. By default, they are converted to 24-bit only if the palette contains more than 256 colors.
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Unpalettized color files (RGB, ARGB, or CMYK) with 1 to 16 bits per plane are converted to 24-bit RGB.
[image: image24.jpg]


Read multipage DICOM files by setting the page number.
You can write DICOM files as 8, 12, or 16-bit grayscale, 8-bit palettized color, or 24-bit RGB color (8 bits per plane).
 XE "DRW " \* MERGEFORMAT DRaWing (DRW)

DRW()DRaWing) is a native format used in the popular Micrografx Designer CAD/CAM/CAE application for the Windows operating system. 

LEADTOOLS supports versions 1, 2, 3, 4 and 5 of the DRW file format.

For DRW files, you can read the following bits per pixel: 24.

 XE "DWF Format (DWF) " \* MERGEFORMAT DWF Format (DWF)

DWF is a binary file format used by AutoDesk AutoCAD for storing DWG files on the World Wide Web. DWF is a 2D, vector-based description of drawings and illustrations. LEAD supports the following DWF object types: Polyline, Polygon, Ellipse (Filled and outlined), Text and Image.

For DWF files, you can read the following bits per pixel: 24.

 XE "DWG Format (DWG) " \* MERGEFORMAT DWG Format (DWG)

DWG is a binary file format used by AutoDesk AutoCAD. It can contain 2D or 3D objects and offers compression and a CRC check for internal data.

LEADTOOLS supports DWG 12, 13, 14 and 15 files with the following object types: TEXT, BLOCK, INSERT, MINSERT, VERTEX_2D, VERTEX_3D, VERTEX_MESH, VERTEX_PFACE, VERTEX_PFACE_MESH, POLYLINE_2D, POLYLINE_3D, ARC, CIRCLE, LINE, POINT, 3DFCE, POLYLINE_PFACE, POLYLINE_MESH, SOLID, TRACE, ELLIPSE, SPLINE, MTEXT and LWPOLYLINE.

LEAD supports the object types listed above, as well as, layers and the grouping of objects. Embedded raster objects are not supported.

For DWG files, you can read the following bits per pixel: 24.

 XE "DXF " \* MERGEFORMAT Drawing Interchange Format (DXF)

DXF (Drawing Interchange Format) was first introduced by AutoDesk AutoCAD, and is one of the most widely used CAD/CAM/CAE application in the world. DXF is very popular and is supported by most 3D formats on PC platforms.
A DXF file is an ASCII file containing 2D and 3D components representing a drawing. Those components are known as Entities. The DXF file can represent almost any CAD drawing using those entities, and can connect a group of entities together (such as windows, doors, etc.) and use them later in the file . The DXF file has seen many changes through the years, from version 2.6 to the latest release version 14. However, the latest release of AutoCAD still manages to open files created with any of the earlier versions. 
LEADTOOLS supports all current variations of the DXF format (versions 2.6, 9, 10, 11, 12, 13, 14) with the following entities: 3DFACE, 3DSOLID, ARC, CIRCLE, ELLIPSE, INSERT, LINE, LWPOLYLINE, MTEXT, POINT, POLYLINE, SOLID, TEXT, and TRACE in full 2D or 3D DXF files. You can load any of the DXF files as either vector images or raster images.
For DXF files, you can read the following bits per pixel: 8.
 XE "Exif file format " \* MERGEFORMAT Exif Formats (TIFF and JPG)

Exif is a standard for image files created with digital cameras and other input devices. The standard is set by the Japan Electronic Industry Development Association, and formally it is called the Digital Still Camera Image File Format Standard.
Exif files contain either uncompressed TIFF images or compressed JPEG images. In addition, these files can contain many comment fields of various types.
LEADTOOLS reads and writes the following Exif formats:
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TIFF. This is a tag-based file format designed to promote universal interchanges of digital image data. You can save any image size.
You can read and write 24 bits per pixel.
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JPG. This is the JPEG format with YUV 4:2:2 sampling. You can save any image size.
You can read and write 24 bits per pixel. (Grayscale is not supported.) For more information, refer to Compression Using LEAD and JPEG Formats.
An Exif JPG file can also contain a stamp (thumbnail) image, which is a small copy of the main image. The stamp stamp size has been restricted to 160x120x24. If you are working with uncompressed (TIFF) Exif files, the stamp size is (width x height x 24 bpp), with no limitations on width and height.
 XE "FLC " \* MERGEFORMAT Flic Animation (FLC)

The Flic file is an animation file created by Auto-desk. This file supports image data but not audio data.

The frames of this file can be of 8bpp image data. The maximum number of frames is 4000.

This file has two versions. The FLI file types support 320 X 200 images with a maximum of 64 colors per image. The FLC file types support up to 64k X 64k images with 256 colors per image.

For FLI files, you can read the following bits per pixel: 8.

For FLC files, you can read and write the following bits per pixel: 8.

 XE "Gerber Format (GBR) " \* MERGEFORMAT Gerber Format (GBR)

The Gerber file format is a vector – based format used by GerbTools, ViewMate and CamTastic as a simple way of transferring printed circuit board information to a wide variety of devices. The Extended Gerber Format (RS-274X) handles information for defining shapes and sizes of lines and other features. This format supports Polygons, Circles, Ovals, Outlines, Arcs, Lines, Rectangles, Moire and Thermal.

For Gerber files, you can read the following bits per pixel: 24.

 XE "Windows Icon " \* MERGEFORMAT 

 XE "Windows Cursor " \* MERGEFORMAT 

 XE "Icon " \* MERGEFORMAT 

 XE "Cursor " \* MERGEFORMAT Icons and Cursors (ICO and CUR)

LEADTOOLS reads and writes Windows Icon and Cursor files. LEADTOOLS is not designed as an icon editor, but this file support lets you create a bitmap from an icon or cursor, or create an icon or cursor from a bitmap. The library (DLL) to support these formats is the same as for BMP files.
LEADTOOLS supports these file formats as follows:
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Windows Icon (ICO). This is a multipage file format for storing one or more Windows icons. The background color when you read these images is always black. The size when you write these images can be no larger than 255-by-255 pixels. (Neither the width nor height can be greater than 255.)
You can read and write 1, 4, 8, 16, 24, and 32-bit, single-page or multi-page files.
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Windows Cursor (CUR). This is a file format for storing Windows cursors (mouse pointers). LEADTOOLS does not load or save transparency information in these files. The size when you write these images should be exactly 32-by-32 pixels.
You can read and write 1, 4, 8, and 24-bit, single-page or multi-page files.
 XE "IFF " \* MERGEFORMAT Interchange File Format (IFF)

IFF is a general purpose data storage format that can associate and store multiple types of data.
IFF reads RLE, and non-compressed images.
IFF writes only RLE compressed images.
For IFF files, you can read and write the following bits per pixel: 1 - 8, 24.
 XE "JBIG " \* MERGEFORMAT JBIG Format (JBG)

JBIG (JBG) is an industry standard lossless compressed file format for bi-tonal (black and white), grayscale and color images. LEAD’s JBIG support is comprehensive and handles the various flavors and bits per pixel as defined by the specification including progressive, where you can store and send multiple representations of images at different resolutions without any extra storage overhead. In order to achieve highest compression ratios available by the JBIG format, LEAD also takes full advantage of all the functional blocks of this robust standard including the Adaptive Arithmetic Encoder, the Adaptive Template Block, the Typical Prediction Block, the Resolution Reduction Block, and the Deterministic Prediction Block. Saving images in a JBIG format results in smaller image files sizes when compared to other industry standard compressed formats such as CCITT G3 or G4. 
For JBIG files, you can read and write the following bits per pixel: 1, 2, 3, 4, 5, 6, 7, 8, 12, 16, 24, 32.
 XE "Wavelet CMP compression " \* MERGEFORMAT 

 XE "LEAD file format " \* MERGEFORMAT 

 XE "JTIF file format " \* MERGEFORMAT 

 XE "JPEG compression " \* MERGEFORMAT 

 XE "JFIF file format " \* MERGEFORMAT 

 XE "CMW file format " \* MERGEFORMAT 

 XE "CMP compression " \* MERGEFORMAT JPEG and LEAD Compressed (JPG, J2K, JP2, CMP, and CMW)

LEADTOOLS reads and writes the following LEAD and JPEG compressed formats:
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LEAD. This is the LEAD CMP compressed format for grayscale and color images. This format results in smaller files and better image quality than industry-standard formats. In addition, LEAD also supports CMW files, which use Wavelet CMP compression in 8, 12, and 16-bit grayscale and 24-bit color.
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Progressive LEAD. This is a LEAD format that is useful for transmitting images, because the first part of the file contains the full dimensions of the image. Therefore, in a paint-while-load routine, you can display the whole image, then progressively clarify it as the rest of the file loads. In this format you can read and write 8 or 24 bits per pixel, where 8 is for grayscale and 24 is for color.
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Lossy JFIF. This is the JPEG File Interchange Format. LEADTOOLS supports YUV 4:4:4, 4:2:2, and 4:1:1 color spacing, and YUV 4:0:0 for grayscale.
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Lossless JFIF. This is the JPEG File Interchange Format. LEADTOOLS supports 8, 12, and 16-bit grayscale and 24-bit color spacing. Please note that not all applications support Lossless JPEG. Before saving a file using Lossless JPEG, make sure your reader supports it.

Both JPEG 4:4:4 and Lossless JPEG will be recognized when getting file information.
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Progressive JPEG. This is a JFIF format that is useful for transmitting images, because the first part of the file contains the full dimensions of the image. Therefore, in a paint-while-load routine, you can display the whole image, then progressively clarify it as the rest of the file loads. LEADTOOLS supports YUV 4:4:4, 4:2:2, and 4:1:1 color spacing, and YUV 4:0:0 for grayscale.
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Lossy JTIF. This is the JPEG Tagged Interchange Format. LEADTOOLS supports YUV 4:4:4, 4:2:2, and 4:1:1 color spacing, and YUV 4:0:0 for grayscale.
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Lossless JTIF. This is the JPEG Tagged Interchange Format. LEADTOOLS supports 8, 12, and 16-bit grayscale and 24-bit color spacing. Please note that not all applications support Lossless JPEG. Before saving a file using Lossless JPEG, make sure your reader supports it.

Both TIFF JPEG 4:4:4 and Lossless JPEG will be recognized when getting file information.
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J2K – Lossy or Lossless. This is a JPEG 2000 Format. LEADTOOLS supports 8, 12, and 16-bit grayscale and 24-bit color spacing. The J2K format contains only a stream of image data. Support for this format is only available in the LEADTOOLS JPEG 2000 Plug in. (12 and 16-bit grayscale support is only in Medical toolkits)
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JP2 – Lossy or Lossless. This is a JPEG 2000 Format. LEADTOOLS supports 8-bit grayscale and 24-bit color spacing. The JP2 format contains a stream of image data, plus extra data about the organization and contents of the file. Support for this format is only available in the LEADTOOLS JPEG 2000 Plug in.
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TIF J2K – Lossy or Lossless. This is a Tagged Image File with JPEG 2000 Compression. This file format contains only a stream of image data. LEADTOOLS supports 8, 12, and 16-bit grayscale and 24-bit color spacing. Support for this format is only available in the LEADTOOLS JPEG 2000 Plug in. (12 and 16-bit grayscale support is only in Medical toolkits)

For general information, refer to Compression Using LEAD and JPEG Formats. 
 XE "PhotoCD " \* MERGEFORMAT 

 XE "PCD file format " \* MERGEFORMAT 

 XE "Multipage files " \* MERGEFORMAT 

 XE "Kodak " \* MERGEFORMAT 

 XE "FPX file format " \* MERGEFORMAT 

 XE "FlashPix file format " \* MERGEFORMAT 

 XE "FlashPix " \* MERGEFORMAT Kodak Formats (PCD and FPX)

LEADTOOLS supports the following Kodak formats:
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PhotoCD (PCD). This is a common high-resolution format for images on CD-ROM. An image file can contain one or more physical resolutions, with fixed dimensions. You can choose which resolution to load, and thus control the size of the resulting bitmap.
You can read the following bits per pixel: 8, 24.
You cannot write PhotoCD files. They are read-only.
[image: image40.jpg]


FlashPix (FPX). (WIN32 only) The FlashPix file format was developed through the combined efforts of Eastman Kodak Company, Microsoft Corporation, Hewlett-Packard Company, and Live Picture Inc. It combines the best features of existing formats with object orientation to make the use of digital color images easier.
The format of a FlashPix file is based on compound object storage, which allows storage of various kinds of data. A FlashPix file may consist of several "pages" where each "page" has storage for a source image, non-image data in the form of comments, transform data, and a stamp or thumbnail. Each image is stored as an entire multi-resolution hierarchy where each resolution in the hierarchy differs from the next highest resolution by a factor of 2 in the x dimension and in the y dimension. Non-image data are treated as comments in FlashPix file format. Comments are used to store information pertaining to the image, not actual pixel data. This information may include image title, image subject, camera manufacturer, scan software version number, and so forth. In addition to the image itself, FlashPix files store transform information. This data indicates transformations which may be performed on the source image. By storing the transforms, the source image may be stored in its original state and transformed, using the stored transforms, at your discretion. A stamp, or thumbnail, provides a small bitmap representation of a FlashPix image. 
You can read and write the following bits per pixel: 8, 24.
 XE "TIFF LZW file format " \* MERGEFORMAT 

 XE "TIFF file format " \* MERGEFORMAT 

 XE "Multipage files " \* MERGEFORMAT 

 XE "Graphics Interchange Format " \* MERGEFORMAT 

 XE "GIF file format " \* MERGEFORMAT GIF and TIFF with LZW Compression

LEADTOOLS reads and writes the following LZW-compressed formats.
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GIF. This is the Graphics Interchange Format created by CompuServe for storing and exchanging color raster images.
You can read and write the following bits per pixel: 1, 2, 3, 4, 5, 6, 7, 8.
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Animated GIF. This is a multipage GIF format that can be played as an animation by displaying the images sequentially. LEADTOOLS lets you create and play the animations.
You can read and write the following bits per pixel: 1, 2, 3, 4, 5, 6, 7, 8.
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TIFF LZW. These files use the Tagged Image File Format with LZW compression. LEADTOOLS can read and write TIFF files that use RGB, CMYK, or YCbCr color space.
You can read the following bits per pixel, without regard for the color space: 1, 2, 3, 4, 5, 6, 7, 8, 16, 24, 32, 48, 64.
You can write the following bits per pixel, with RGB color space: 1, 2, 3, 4, 5, 6, 7, 8, 16, 24, 32, 48, 64.
You can write the following bits per pixel, with CMYK color space: 24, 32.
You can write the following bits per pixel, with YCbCr color space: 24.
You can write 16- bit grayscale.
 XE "PBM " \* MERGEFORMAT Portable Bitmap Utilities (PBM)

The Portable Bitmap Utilities consists of Portable Greymap Utilities (PGM), Portable Pixmap Utilities (PPM), and Portable Anymap Utilities (PNM). Their source is the UNIX environment.
For PBM files, you can read and write the following bits per pixel: 1.
For PGM files, you can read and write the following bits per pixel: 8 (Grayscale).
For PPM files, you can read and write the following bits per pixel: 24.
 XE "Printer Command Language (PCL) " \* MERGEFORMAT 

 XE "PCL " \* MERGEFORMAT Printer Command Language Format (PCL)

The Printer Command Language vector format was developed by Hewlett-Packard, specifically to provide a means of communication between computers and printers. The PCL files contain the commands and the HP printers parse and decode those commands. 

The default extensions used by this format are: PRN, PRT, PLT, HGL, HPG and PGL.

This format is used by Visual PCL and AutoVue.

This file format does not support layers or grouping, but it does support embedded raster objects. LEAD supports all objects.

For PCL files, you can read the following bits per pixel: 24.

 XE "PCT file format " \* MERGEFORMAT 

 XE "Microsoft Paint file format " \* MERGEFORMAT Macintosh Pict Format (PCT)

Macintosh Pict (PCT) files are produced using Macintosh QuickDraw, and are used in desktop publishing and imaging applications. 
PCT Vector files can be read as raster images. LEADTOOLS supports multiple page files when reading PCT images as raster images.
For PCT files, you can read the following bits per pixel: 1, 4, 8, 16, 24.

 XE "ZSoft " \* MERGEFORMAT 

 XE "PCX file format " \* MERGEFORMAT 

 XE "Multipage files " \* MERGEFORMAT 

 XE "DCX file format " \* MERGEFORMAT PCX Formats (PCX and DCX)

LEADTOOLS reads and writes the following PCX formats:
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PCX. This is a file format created by ZSoft. This format compresses its image data with the RLE type compression.
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DCX. This is a multipage PCX format that enables a file to contain more than one image. It is handled the same as a regular PCX file, except for the multipage feature.
For PCX and DCX files, you can read and write the following bits per pixel: 1, 4, 8, 24.
 XE "Portable Document Format file format " \* MERGEFORMAT 

 XE "PDF file format " \* MERGEFORMAT 

 XE "PDF " \* MERGEFORMAT Portable Document Format (PDF)

Portable Document Format (PDF). PDF was developed by the Adobe Corporation to allow the exchange and viewing of electronic documents easily and reliably, independent of the environment in which they were created. This format lets you compress large documents to a size small enough to download very quickly. It is also becoming a powerful format for reproducing documents over the web.
For a PDF file, you have the option of loading it at the following bits per pixel: 1, 2, 4, 8, 24.
For a PDF file, you can write the following bits per pixel: 1, 2, 4, 8, 24.
 XE "PLT " \* MERGEFORMAT PLT (PLT)

PLT (also HPGL) is the standard language for printing line drawings created by Hewlett-Packard. HPGL is supported by many CAD programs, charting programs and word processors.

LEADTOOLS supports HPGL and HPGL/2. 

For HPGL files, you can read the following bits per pixel: 4.

For HPGL/2 files, you can read the following bits per pixel: 4.

 XE "Portable Network Graphics file format " \* MERGEFORMAT 

 XE "PNG file format " \* MERGEFORMAT Portable Network Graphics Format (PNG)

PNG (Portable Network Graphics) is a replacement for the GIF format. It is a full-featured (non-LZW) compressed format intended for widespread use without legal restraints.

You can read the following bits per pixel: 1, 4, 8, 16, 24, 32.

You can write the following bits per pixel: 1, 4, 8, 24, 32.

LEADTOOLS supports reading (but not writing) interlaced PNG files.
 XE "PostScript " \* MERGEFORMAT 

 XE "EPS file format " \* MERGEFORMAT 

 XE "Encapsulated PostScript file format " \* MERGEFORMAT Encapsulated PostScript (EPS)

PostScript Raster (Encapsulated PostScript). These files are used primarily on PostScript printers. These printers usually offer more variety of fonts and higher resolution than standard laser printers. EPS files will work on any PostScript compatible printer and any end-user application that supports placement of EPS files in its work space.
The image that you read from an EPS file can be either a PostScript raster image, an embedded TIFF image, or an embedded WMF image. The image that you write to an EPS file is always a PostScript raster image.
For a PostScript raster image, you can read the following bits per pixel: 1, 8.
For an embedded TIFF image, you can read the following bits per pixel: 1, 4, 8, 16, 24, 32.
For an embedded WMF file, you can read the following bits per pixel: 24.
You can write only an 8-bit PostScript raster image, which is grayscale.
 XE "PSD file format " \* MERGEFORMAT 

 XE "Photoshop file format " \* MERGEFORMAT 

 XE "Adobe Photoshop " \* MERGEFORMAT PhotoShop 3.0 Format (PSD)

Photoshop 3.0 (PSD) is the format produced by the Adobe Photoshop graphics editor.

For PSD files, you can read and write the following bits per pixel: 1, 8, and 24.
You can also read and write layers to this file with the following bits per pixel: 8 (GrayScale), 24, and 32.
 XE "PTOCA (PTOCA) " \* MERGEFORMAT 

 XE "PTOCA " \* MERGEFORMAT PTOCA Format (PTOCA)

The Presentation Text Object Content Architecture (PTOCA) is the data object used in document processing environments for representing text, which has been prepared for presentation. Each file contains one or more pages of text and is always included as part of a document in a MODCA file. Each page may reference a PTOCA Overlay, which is merged with the text as a background.

There is no default extension.

This format originated at IBM.

This file format does not support QFactor, progressive loads and saves, stamps or Lossless JPEG compression, but it does support multi-page files.

For PTK files, you can read the following bits per pixel: 24.

LEAD does not save PTK files.

 XE "SCT " \* MERGEFORMAT 

 XE "Scitex Continuous Tone Format (SCT) " \* MERGEFORMAT Scitex Continuous Tone Format (SCT)

The Scitex Continuous Tone file format was developed by Scitex and is used for high-end image processing. The SCT/CT files are used primarily to store CMY and CMYK color space for the image. For saving the SCT file format, LEAD saves it as CMY instead of CMYK. This maintains the image quality, since the conversion from RGB to CMYK will result in some loss of data.

The default extensions used by this format are: SCT and CT.

This file format does not support progressive loads and saves, multi-page files, stamps, or Lossless JPEG compression.

For SCT/CT files, you can read the following bits per pixel: 24, 32.

For SCT/CT files, you can write the following bits per pixel: 24.

 XE "Silicon Graphics Image Format (SGI) " \* MERGEFORMAT 

 XE "SGI " \* MERGEFORMAT Silicon Graphics Image Format (SGI)

The SGI file formats was developed at Silicon Graphics, and is used for black and white, gray-scale and color images. LEADTOOLS supports both uncompressed SGI and RLE compressed SGI.

For SGI files, you can read and write the following bits per pixel: 8, 24, 32.

 XE "SHP " \* MERGEFORMAT 

 XE "ESRI Shape (SHP) " \* MERGEFORMAT ESRI Shape Format (SHP)

The ESRI Shape format is a vector format created by the Environmental System Research Institute. The SHP file can support point, multi-point, polygon, polyline and multi-patches. This file format has a much faster drawing speed and more editing capabilities than other data sources. It is supported by the ArcExplorer GIS Data Viewer.

The default extension used by this format is: SHP.

This file format does not support layers, grouping objects or embedded raster objects. 

LEAD supports the Vertex, Polygon and Polyline objects, but it does not support the Multi-vertex and Multi-patch.

For SHP files, you can read the following bits per pixel: 24.

 XE "SUN Raster file format " \* MERGEFORMAT 

 XE "RAS file format " \* MERGEFORMAT SUN Raster Format (RAS)

SUN Raster (RAS) is a format native to Sun UNIX platforms.
For RAS files, you can read and write the following bits per pixel: 1, 4, 8, 24, 32.
 XE "Truevision " \* MERGEFORMAT 

 XE "TGA file format " \* MERGEFORMAT 

 XE "TARGA file format " \* MERGEFORMAT Truevision TARGA Format (TGA)

Truevision TGA (TARGA) is a file format created by Truevision Inc. LEADTOOLS supports all uncompressed and RLE compressed TGA file formats.
For TGA files, you can read and write the following bits per pixel in either uncompressed or RLE compressed form: 8, 16, 24, 32.
 XE "TIFF file format " \* MERGEFORMAT 

 XE "Multipage files " \* MERGEFORMAT TIFF Without LZW Compression

LEADTOOLS reads and writes several TIFF formats that do not require an LZW license.
TIFF is a tag-based file format designed to promote universal interchanges of digital image data. Because TIFF files do not have a single way to store image data, there are many versions of TIFF. LEADTOOLS supports the most common TIFF formats. The usual file extension is TIFF for single-image files, and MPT for multipage files (which can contain many images). TIFF files can contain many comment fields of various types.
LEADTOOLS can read and write TIFF files that use RGB, CMYK, or YCbCr color space. LEADTOOLS can also read and write files with PackBits compression.
LEADTOOLS can also read and write files with Lossless JPEG compression for 8, 12, and 16-bit grayscale and 24-bit color spacing.
LEADTOOLS can also read and write files with CMP Compression for 8-bit grayscale and 24-bit color.
LEADTOOLS can also read and write files with JBIG Compression for the following bits per pixel: 1, 2, 3, 4, 5, 6, 7, 8, 12, 16, 24, 32.
You can read the following bits per pixel, without regard for the color space: 1, 2, 3, 4, 5, 6, 7, 8, 16, 24, 32, 48, 64.

You can write the following bits per pixel, with RGB color space: 1, 2, 3, 4, 5, 6, 7, 8, 16, 24, 32, 48, 64.
You can write the following bits per pixel, with CMYK color space: 24, 32.
You can write the following bits per pixel, with YCbCr color space: 24.
You can read and write 12- bit grayscale.
You can write 16- bit grayscale.
 XE "Wireless Bitmap Format (WBMP) " \* MERGEFORMAT Wireless Bitmap Format (WBMP)

The Wireless Bitmap file format is a 1-bit format used to send graphical information to a variety of handsets. It is terminal independent and describes only graphical information.

For Wireless Bitmap files, you can read the following bits per pixel: 1.

For Wireless Bitmap files, you can write the following bits per pixel: 1.

 XE "WMF file format " \* MERGEFORMAT 

 XE "Windows metafile " \* MERGEFORMAT 

 XE "Metafile " \* MERGEFORMAT Windows Metafile Formats (WMF and EMF)

The Windows Metafile (WMF and EMF) formats are vector formats that may or may not also contain a raster image. 
EMF/WMF Vector files can be read as raster images.

For WMF and EMF files, you can read the following bits per pixel: 8, 24.
Note: EMF is supported only in WIN32.
 XE "WPG file format " \* MERGEFORMAT 

 XE "WordPerfect file format " \* MERGEFORMAT WordPerfect Format (WPG)

The WordPerfect (WPG) format can contain vectored or raster images. LEADTOOLS handles only the raster images.
For WPG files, you can read and write the following bits per pixel: 1, 4, 8.
 XE "XPM " \* MERGEFORMAT XPicMap Format (XPM)

XPM files are used to store X Window PixMap information to disk. They are capable of storing black-and-white, grayscale, and color images. XPM stores image data in the form of ASCII text formatted as a standard C character string array.
For XPM files, you can read and write the following bits per pixel: 1, 8, 24.
 XE "XWD " \* MERGEFORMAT X Window Dump (XWD)

XWD stands for X Window dump. This file format is used to store and restore screen window images. Two versions of this file exist, the X10 window dump and the X11 window dump. These versions differ slightly in the format of the data (i.e. headers and bits per pixel).

The version X10 XWD file cannot have more than 8bpp image data.

For the version X10 XWD files, you can read and write the following bits per pixel: 1, 4, 8.

For the version X11 XWD files, you can read and write the following bits per pixel: 1, 4, 8, 16. 24, 32.

Bitonal (1-Bit)

 XE "MODCA " \* MERGEFORMAT 

 XE "IOCA " \* MERGEFORMAT 

 XE "Image Object Content Architecture (IOCA/MODCA) " \* MERGEFORMAT Image Object Content Architecture Format (IOCA/MODCA)

The Image Object Content Architecture format was developed by IBM. This architecture provides a consistent way to represent images, including conventions and directions for processing and interchanging image information. LEADTOOLS supports single and multi-page files in a MO:DCA wrapper with embedded 1-bit CCITT, Group 3 or Group 4 images, IBM MMR and uncompressed IOCA. LEAD also supports IOCA files without the MO:DCA wrapper. LEAD loads and saves all these formats.

The default extension used by this format is: ICA.

This file format does not support stamps or Lossless JPEG compression, but it does support multi-page files. For this file format, LEAD supports CCITT, G3(1D, 2D), CCITT G4, IBM MMR compression, and uncompressed files. LEAD does not support ABIC, RL4, and Color Compression used by OS/2.

For IOCA files, you can read the following bits per pixel: 1.

For IOCA files, you can write the following bits per pixel: 1.

 XE "ITG file format " \* MERGEFORMAT 

 XE "IntergraphRLE " \* MERGEFORMAT IntergraphRLE (ITG)

Intergraph is a monochrome bitmap format developed by Intergraph. LEADTOOLS supports the RLE and CIT versions of this file format.

The default extensions used by this format are: ITG and CIT.

This file format does not support stamps or Lossless JPEG compression. For this file format, LEAD supports CCITT G4 and RLE compression. 

Currently LEAD writes only the ITG format.

For ITG and CIT files, you can read the following bits per pixel: 1.

For ITG files, you can write the following bits per pixel: 1.

 XE "LEAD 1-bit file format " \* MERGEFORMAT 

 XE "CMP file format " \* MERGEFORMAT LEAD 1-Bit Format (CMP)

LEAD 1BIT is a proprietary 1-bit LEAD compressed format that has better compression and performance than other 1-bit formats.
You can read and write files in this format.
 XE "MSP file format " \* MERGEFORMAT 

 XE "Microsoft Paint file format " \* MERGEFORMAT 

 XE "MacPaint file format " \* MERGEFORMAT 

 XE "MAC file format " \* MERGEFORMAT 

 XE "IMG file format " \* MERGEFORMAT 

 XE "GEM Image file format " \* MERGEFORMAT Miscellaneous 1-Bit Formats (MAC, IMG, and MSP)

LEADTOOLS supports reading and writing of the following 1-bit formats:
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MacPaint (MAC). These Macintosh Paint files are commonly used for monochrome clip art.
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GEM Image (IMG). These files are native to the Graphical Environment Manager developed by Digital Research.
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Microsoft Paint (MSP). These files from early versions of Windows are used for black-and-white drawings and clip art.
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JBIG. JBIG compression was designed primarily for bi-level images, however it can also compress grayscale and color images.
 XE "SMP " \* MERGEFORMAT SMP Format (SMP)

The SMP file contains a 1-bit raster bitmap. It may be uncompressed, compressed using CCITT Group 3 or compressed using CCITT Group 4. LEADTOOLS supports loading and saving for all these types.

The default extension is .SMP.

This format was created by Xionics and is used in PixEdit for Techsoft.

This file format does not support QFactor, progressive loads and saves, multi-page files, stamps or Lossless JPEG compression.

For SMP files, you can read the following bits per pixel: 1.

For SMP files, you can write the following bits per pixel: 1.

 XE "WinFax file format " \* MERGEFORMAT 

 XE "TIFF file format " \* MERGEFORMAT 

 XE "Multipage files " \* MERGEFORMAT 

 XE "IOCA file format " \* MERGEFORMAT 

 XE "ICA file format " \* MERGEFORMAT 

 XE "FAX transmission file format " \* MERGEFORMAT 

 XE "FAX Group 4 file format " \* MERGEFORMAT 

 XE "FAX Group 3 file format " \* MERGEFORMAT 

 XE "CCITT Group 4 file format " \* MERGEFORMAT 

 XE "CCITT Group 3 2D file format " \* MERGEFORMAT 

 XE "CCITT Group 3 1D file format " \* MERGEFORMAT 

 XE "CCITT file format " \* MERGEFORMAT 

 XE "AWD file format " \* MERGEFORMAT TIFF CCITT and Other FAX Formats

LEADTOOLS supports reading and writing of the following 1-bit formats that are commonly used in FAX transmissions:
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TIFF CCITT. These are compressed TIFF files that are commonly used for FAX transmission and document imaging.
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TIFF CCITT Group 3. These are TIFF CCITT files in a format that is more advanced and more compressed than TIFF CCITT. LEADTOOLS supports both 1-dimension and 2-dimension variations of this format.
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TIFF CCITT Group 4. These are TIFF CCITT files in a format that is more advanced and more compressed than TIFF CCITT Group 3.
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CALS Raster(Type 1, 2, 3, and 4). These are CCITT Group 4 CALS raster files. CALS is a United States government standard. CALS3 are multipage files.
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IOCA (ICA). This is the Image Object Content Architecture developed by IBM. LEADTOOLS supports these files in an MO:DCA wrapper with embedded 1-bit CCITT Group 3 or Group 4 images. LEADTOOLS also supports IOCA files without an MO:DCA wrapper.
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WinFax Group 3. This is a FAX format created by Delrina for Group 3 support.
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WinFax Group 4. This is a FAX format created by Delrina for Group 4 support.
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FAX Group 3. This is a raw FAX format (without a header) for Group 3 support. LEADTOOLS supports both 1-dimension and 2-dimension variations of this format.
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FAX Group 4. This is a raw FAX format (without a header) for Group 4 support.
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AWD. (WIN32 only) This is a Microsoft FAX format.
 XE "XBM file format " \* MERGEFORMAT 

 XE "XBitMap " \* MERGEFORMAT XBitMap (XBM)

XBM is a monochrome bitmap format in which data is stored as a C language data array. It is primarily used for the storage of cursor and icon bitmaps, for use in the X graphical user interface.
For XBM files, you can read and write the following bits per pixel: 1.
Graphical User Interface

Windows

 XE "LEADTOOLS Screen Capture Application Main Window " \* MERGEFORMAT LEADTOOLS Screen Capture Application Main Window

Each captured image will be opened as a separate file that is displayed in the main window. A standard Windows title bar appears across the top of each window:
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If you minimize the application, an icon will appear in the system tray:
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When you click the right mouse button on the tray icon, the following menu will appear:
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To return to the main window, select Restore.

To see thumbnail images of all captured images currently open, open the Captured Images Window.
 XE "Captured Images Window " \* MERGEFORMAT Captured Images Window

The Captured Images window displays thumbnail images of all captured images currently open. To open the thumbnail list, from the main menu select Options -> Show Thumbnails.

To quickly copy, paste, delete, or export images, right-click any thumbnail to open the Context Menu. You can also select one or more thumbnail images using the keyboard or mouse.
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Menus

 XE "LEADTOOLS Screen Capture Application Menus " \* MERGEFORMAT LEADTOOLS Screen Capture Application Menus

LEADTOOLS Screen Capture Application has two menu types:
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The Main Menu appears in the menu bar at the top of your screen.
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A Context Menu will pop-up if you right-click a thumbnail image in the Captured Images Window. 
Menu commands can be displayed by either:
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Clicking the menu title in the menu bar, or
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Pressing <Alt>+ <the underlined letter in the menu title>.

Menu commands can be selected or executed by:
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Clicking the item in the drop-down menu list, 
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Pressing the letter underlined in the menu list, or
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Using the cursor or the <>, and <> keys to highlight a menu item, then left-clicking or-pressing <Enter>.

For example, to select the menu item File > Open using your keyboard:
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Press <Alt> + <F>, then <O>.

 XE "Context Menu " \* MERGEFORMAT Context Menu

Click the right-mouse button over any thumbnail in the Captured Images Window to display the Context Menu:
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The following table lists the commands and their descriptions available from the Context menu:

	Command
	Description

	Copy
	Copy the selected item into the Windows clipboard.

	Delete
	Deleted the selected item(s) from the image list.

	Save
	Saves the selected item(s). This will display the Save Images Dialog, allowing you to specify the file name and the export format.

	Export All
	Saves all items (all captured images) into a multi-page file. This will display the Save Images Dialog, allowing you to specify the file name and the export format.


Main Menu

 XE "Main Menu " \* MERGEFORMAT Main Menu

LEADTOOLS Screen Capture’s commands are grouped into several categories. The main headings for each of these categories appear in the menu bar, usually docked at the top of the workspace just below the title bar. Click a menu heading to open the menu and choose a command. Commands that you may use frequently are also displayed on the toolbar(s).

	Note:
	Menu layouts can change depending on the number of images open. Menu items that appear in gray either do not apply or are unavailable.


LEADTOOLS Screen Capture Application main menu titles are:

File Menu
Capture Menu
Options Menu
View Menu
Window Menu
Help Menu
 XE "File Menu " \* MERGEFORMAT File Menu
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The following table lists the commands and their descriptions available from the File menu:

	Command
	Description

	Open
	Displays the Open Dialog. From there, you can open and capture resources from EXEs or DLLs.

	Close
	Closes the active captured image.

	Close All
	Closes all capture images.

	Save
	Saves the active captured images. This command will display the Save a Captured Image to File Dialog.

	Recently Opened Image(s)
	A list of the most recently opened files in LEADTOOLS Screen Capture appears before the Exit option. Select one of these images to open it. If LEADTOOLS Screen Capture fails to open an image for any reason, it will be removed from the list.

	Exit
	Use to end your working session and exit LEADTOOLS Screen Capture. Alternatively, press <Alt>+<F4>. If there are any unsaved images, a dialog will appear asking you to save, cancel, or abort.


 XE "Capture Menu " \* MERGEFORMAT Capture Menu

This menu allows you to specify the capture object type for the next capture or series of captures.
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The following table lists the commands and their descriptions available from the Capture menu:

	Command
	Description

	Active Window
	Causes the capture function, when invoked, to capture the current window.

	Active Client
	Causes the capture function, when invoked, to capture the current window, excluding the window’s title and borders.

	Full Screen
	Causes the capture function, when invoked, to capture everything that appears on your screen.

	Selected Object
	Causes the capture function, when invoked, to let you select an object to capture. After you press the capture key, move the mouse cursor over an object to highlight it, then click to capture it.

	Menu Under Courser
	Causes the capture function, when invoked, to capture the current pull-down menu.

	Window Under Courser
	Causes the capture function, when invoked, to capture the window that the mouse cursor is on.

	Area
	Shows possible types in an Area.

	Mouse Courser
	Causes the capture function, when invoked, to capture the mouse cursor.

	Capture Wallpaper
	Performs an immediate capture of current wallpaper. If there is no wallpaper set, nothing is captured.

	CaptureFromExeDlg (TreeView)
	Opens resources such as bitmaps, icons or cursors from EXEs or DLLs, allowing you to capture these resources and save them as image files. This command will display the Capture From Executable File Dialog.

	CaptureFromExeDlg (TabView)
	Opens resources such as bitmaps, icons or cursors from EXEs or DLLs, allowing you to capture these resources and save them as image files. This command will display the Capture From Executable File Dialog.

	Capture From Executables
	Allows capturing a resource from an EXE or DLL file that contains image resources like bitmaps, icons and cursors. When you select an EXE or DLL file, the available resources will be displayed in a combo box. You can then select the resource type and enter the resource ID, then Preview to see the requested resource. This command will display the Capture From Exe Dialog.

	Stop Capture
	Used to end the capture process and "release" the capture hotkey. The capture can also be ended by pressing a Cancel hotkey. This can be designated in the Capture Options Dialog.


 XE "Area Sub Menu " \* MERGEFORMAT Area Sub Menu

This sub menu is used to specify the shape of the area captured:
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To reach this menu, from the main menu select Capture -> Area. 

The following table lists the command names and their description available from the Area sub menu:

	Command
	Description

	Rect
	Allows you select a rectangular area for capture. To define the area, select the starting position by clicking the left mouse button, then drag the cursor and release the left mouse button to define the bounding-area for the shape.

	Rounded Rect
	Allows you select a rounded rectangular area for capture. To define the area, select the starting position by clicking the left mouse button, then drag the cursor and release the left mouse button to define the bounding-area for the shape.

	Ellipse
	Allows you select an elliptical area for capture. To define the area, select the starting position by clicking the left mouse button, then drag the cursor and release the left mouse button to define the bounding-area for the shape.

	Polygon
	Allows you select a polygonal area for capture. To define the area, select the starting position by clicking the left mouse button and releasing it. Then drag the cursor and click at each of the corner points of the polygon to define the bounding-area for the shape. Double-click to close the shape.

	Free Hand
	Allows you select a freehand area for capture. To define the area, select the starting position by clicking the left mouse button, then drag the cursor and release the left mouse button to define the bounding-area for the shape.

	Triangle
	Allows you select a triangular area for capture. To define the area, select the starting position by clicking the left mouse button, then drag the cursor and release the left mouse button to define the bounding-area for the shape.


 XE "Options Menu " \* MERGEFORMAT Options Menu

This menu allows you to specify capture options before starting the capture process:
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The following table lists the commands and their descriptions available from the Options menu:

	Command
	Description

	Capture Options
	Displays the Capture Options Dialog, used to set up general capture options.

	Capture Area Options
	Displays the Capture Area Options Dialog, used to set up area capture options.

	Capture Objects Options
	Displays the Capture Object Options Dialog, used to set up object capture options.

	Show Thumbnails
	Displays the Captured Images Window, used to to view all captured images as thumbnails in an image list window.


 XE "View Menu " \* MERGEFORMAT View Menu

This menu allows you to show or hide the toolbar and status bar
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The following table lists the commands and their descriptions available from the View menu:

	Command
	Description

	Toolbar
	Select this item to show or hide the toolbar.

	Status Bar
	Select this item to show or hide the status bar.


 XE "Window Menu " \* MERGEFORMAT Window Menu

This menu allows you to arrange the panes in the main window.
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The following table lists the commands and their descriptions available from the Window menu:

	Command
	Description

	Cascade
	Used to move and resize the entire opened image windows so that they overlap in a stacked fashion, with each window’s position slightly offset down and to the right from the one below it. Use Cascade when you want to view all of the image view windows’ title bars.

	Tile
	Used to move and resize all of the open image windows so that they all become visible and completely cover the workspace without overlapping.

	Arrange Icons
	Used to arrange all of the minimized image view window icons into a grid.


 XE "Help Menu " \* MERGEFORMAT Help Menu

The Help menu allows you to access help information
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The following table lists the commands and their descriptions available from the Help menu:

	Command
	Description

	About
	Displays an About Dialog for the LEADTOOLS Screen Capture Application.

	Help
	Displays this help file.


Dialogs

 XE "LEADTOOLS Screen Capture Application Dialogs " \* MERGEFORMAT LEADTOOLS Screen Capture Application Dialogs

Use the following dialogs to set LEADTOOLS Screen Capture Application options:

	Open Dialog
	Save Images Dialog

	Save a Captured Image to File Dialog
	Capture Object Options Dialog

	Capture Area Options Dialog
	Capture Options Dialog

	Capture From Executable File Dialog (Tree View)
	Capture From Exe Dialog

	Capture From Executable File Dialog (Tab View)
	About Dialog


 XE "About Dialog " \* MERGEFORMAT About Dialog

Use the About dialog to get information about the LEADTOOLS Screen Capture Application.

To display the About dialog, from the main menu, select Help -> About Screen Capture…
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 XE "Capture Area Options Dialog " \* MERGEFORMAT Capture Area Options Dialog

Use the Capture Area Options dialog to set capture area options.

To display the Capture Area Options dialog, from the main menu, Options -> Capture Area Options…
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The following are the fields in the Capture Area Options dialog:

Area Type

Use to choose the shape that you wish to capture. Available shapes are rectangle, rounded rectangle, ellipse, triangle, polygon, and freehand.

Note: Rounded Rectangle shape uses the values of ellipse width and ellipse height to define its corners.

Draw Line Style

Use to choose the line style for the visible border during the process of area selection.

Fill Pattern

Use to choose the pattern that will be used to fill the background of the capture.

There will be some background area to fill for any non-rectangular capture, as the captured area will be placed onto the smallest rectangle that can fully contain it.

Draw Cursor

Use to choose the cursor that will be displayed during the area selection. This is only enabled if the Cross Line Cursor checkbox is not checked.

Ellipse Width

Use to set the size of the ellipses that will be used for the corners of the Rounded Rectangle shape area capture.

Ellipse Height

Use to set the size of the ellipses that will be used for the corners of the Rounded Rectangle shape area capture.

Include Cursor In Captured Area

Use to specify if the capture cursor (defined in the General Capture Options Dialog) will appear at the mouse-cursor location (if it inside the captured area) at the time of start-capture.

Cross Line Cursor

Use to use the default cross line cursor for area selection.

Bitmap With Region

Use to create an image from the screen capture with the current selection set to the shape, which was captured.

Show Draw Cursor

Use to enable or disable the visibility of the area-selection cursor.

Enable Keyboard

Use to allow <Ctrl>, <Shift>, <+>, < - > keys during capture.

<+> or < - > keys are used for zooming in or zooming out in the info window.

If an area is a rectangle, round rectangle, or ellipse, pressing <Ctrl> key will center the drawing

If an area is a rectangle, round rectangle, or ellipse, pressing <Shift> key will draw regular shapes (that is ellipse becomes a circle, rectangle becomes a square, etc.)

Position X

Use to set the info-window position to left, right, or custom.

Position Y

Use to set the info window position to top, bottom, or custom.

Width

Use to set the width of the info window to Tiny, Small, Medium, Large, X-Large or custom.

Height

Use to set the height of the info window to Tiny, Small, Medium, Large, X-Large or custom.

Custom Values

When position or size is custom, use edit boxes to set custom values.

Position X

Use to set the info window x position value when Position X drop-down box is set to custom.

Position Y

Use to set the info window y position value when Position Y drop-down box is set to custom.

Width

Use to set the info window width value when Width is set to custom.

Height

Use to set the info window Height value when Height is set to custom.

Zoom

Use to set the amount of magnification applied to the pixels around the mouse cursor when viewed in the info window.

Show Cursor Position

Use to show the cursor position in the info window.

Show Info Window

Use to enable or disable visibility of info window.

Show Capture Size

Use to show capture size information in the info window.

Sensitive Info Window

Use to enable/disable Sensitive detection for the Info window position.

Show Opaque Text

Use to enable or disable text-background opacity in the information-box tool-tips showing position and size of captured area.

Color Group

Select the attribute you want to customize from the drop down list box, then choose the desired color with the Set Color button.

This drop-down list has the following options:
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Area Fill Foreground, sets the area fill foreground color.
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Area Fill Background, for non-rectangular captures, any portion of the resulting image that is not contained within the user-defined selection will be filled with this color.
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Draw Polygon/Freehand Line, sets the color of the line that marks the polygonal or freehand capture selection boundary while it is being drawn.
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Cursor Position/Area Size Text, sets the color of the text in the information-box tool-tip showing position and size of captured area while the selection is being drawn.
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Cursor Position/Area Size Background, sets the color of the background in the information-box tool-tip showing position and size of captured area while the selection is being drawn.

Set Color

Use to select a color from the color palette, and close when finished. This color will be associated with the corresponding attribute selected in the list box.

Default

Press to restore default dialog options.

OK

Press to close the dialog and save the changes.

Cancel

Press to close the dialog and discard the changes.

 XE "Capture From Executable File Dialog (Tab View) " \* MERGEFORMAT Capture From Executable File Dialog (Tab View)

Use the Capture From Executable File Dialog (Tab View) to capture resource images, icons, etc. from an EXE or DLL file.

To display the Capture From Executable File Dialog (Tab View), from the main menu, select Capture -> CaptureFromExeDlg (TabView).
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The following are the fields in the Capture From Executable File Dialog (Tab View):

Tab

Shows and selects the images, icons, etc. stored in EXE or DLL files.

Preview

Use to view the selected recourse to capture.

Red Slider

Use this slider to set the red color degree of the selected image.

Blue Slider

Use this slider to set the blue color degree of the selected image.

Green Slider

Use this slider to set the green color degree of the selected image.

Browse

Use to browse to a specific EXE or DLL file that contains resources.

Capture

Use to begin capture for the selected resource in the tree control. If no resource item is selected, this button will be disabled.

Close

Close the dialog.

 XE "Capture From Executable File Dialog (Tree View) " \* MERGEFORMAT Capture From Executable File Dialog (Tree View)

Use the Capture From Executable File Dialog (Tree View) to capture resource images, icons, etc. from EXE or DLL files.

To display the Capture From Executable File Dialog (Tree View), from the main menu, select Capture -> CaptureFromExeDlg (TreeView).
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The following are the fields in the Capture From Executable File Dialog (Tree View):

Tree

Shows and selects images, icons, etc. stored in an EXE or DLL file.

Preview

Used to view the selected resourse to capture.

Red Slider

Use this slider to set the red color degree of the selected image.

Blue Slider

Use this slider to set the blue color degree of the selected image.

Green Slider

Use this slider to set the green color degree of the selected image.

Browse

Use to browse a specific EXE or DLL file that contains resources.

Capture

Use to start capture of the selected resource in the tree control. If no resource item is selected, this button will be disabled.

Close

Close the dialog.

 XE "Capture From Exe Dialog " \* MERGEFORMAT Capture From Exe Dialog

Use the Capture From Exe Dialog to capture resource images, icons, etc. from an EXE or DLL file.

To display the Capture From Exe Dialog, from the main menu, select Capture -> Capture From Executable…
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The following are the fields in the Capture From Exe Dialog:

Exe Name

Shows the EXE or DLL file name that contains the resource images, icons, etc…

Resource Type

Use this drop-down list box to select the type of the resource item to be captured. Options are:
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1-Bitmaps
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2-Icons
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3-Cursors

Count

Shows the number of resource items of a specific resource type.

Resource ID

Sets the resource item ID.

Resource ID Is

Used to detect the type of using the resource item ID, the possible options are:
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as DWORD value
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as STRING value
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as INDEX value

Preview

Use to view the selected recourse to capture. If no valid ID is entered in the Resource ID, then this button will be disabled.

OK

Use to start capture the selected resource in the tree control. If no resource item is selected, this button will be disabled.

Cancel

Close the dialog.

 XE "Capture Object Options Dialog " \* MERGEFORMAT Capture Object Options Dialog

Use the Capture Selected Object Options dialog to set capture selected object options, like cursor, border, and other options for use during object capture.

To display the Capture Object Options dialog, from the main menu, choose Options -> Capture Object Options…
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The following are the fields in the Capture Object Options dialog:

Draw Cursor

Use to set the cursor which will be visible during the object capture operation.

Border Width

Use to set the width of the border which will appear around objects under the cursor during object capture.

Invert Selected Object

Use to cause the object under cursor to appear in inverted colors during object capture.

Enable Key Board

Use Enable the <Shift> key during the selection process. Pressing the <Shift> key will select the interior area of the object.

Default

Press Default button to restore default settings of all dialog options.

OK

Use OK button to close the dialog and save the changes.

Cancel

Use Cancel button to close the dialog and discard the changes.

 XE "Capture Options Dialog " \* MERGEFORMAT Capture Options Dialog

Use the Capture Options dialog to set up some general capturing preferences like hotkey, multi-capture settings, and cursor options

To display the Capture Options dialog, from the main menu, choose Options -> Capture Options…
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The following are the fields in the Capture Options dialog:

HotKey

Use to set the key that you will be using to trigger screen capture. Click inside the edit box and then press the key you wish to use. The screen capture hotkey is <F11> by default.

Delay

Use to set the time interval to wait between pressing the HotKey and beginning capture. This value defaults to 0 (capture starts immediately).

Repeat

Use to set the number of captures to perform. This value defaults to 1.

Interval

Use to specify how long to wait between captures. Only applicable if repeat value is greater than 1.

Cancel Key

Use to specify which key to use to stop and abort capture process. This box is disabled if the Use Esc Key check box is checked.

Use Esc Key

Use to specifies that <Esc> key is to be used to end capture.

Captured Cursor

Use to set the cursor that is placed onto the captured image, to choose no cursor, select the cursor with cross upon it.

Delay Cursor

Use to set the combo box to set the cursor to use between multiple captures, to choose no cursor, select the cursor with cross upon it.

OK

Use OK button to close the dialog and save the changes.

Cancel

Use Cancel button to close the dialog and discard the changes.

 XE "Open Dialog " \* MERGEFORMAT Open Dialog

Use the Open dialog to browse to folders for a specific EXE or DLL file that contains resource images or icons.

To display the Open dialog, from the main menu, choose File -> Open... or press <Ctrl> + <O>.
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The following are the fields in the Open dialog:

Look in

Use the Look in dropdown list box to select the drive or folder that your EXE or DLL files are stored in. When you select drive or folder from the list, the contents of the selected drive of folder will appear.

File Name

Use the File Name edit box to type the name and path of the file you wish to open.

Files of type

Use Files of type dropdown list box to select the file type, either EXE or DLL that you wish to open.

Open

Use Open button to open the selected file, the dialog box closes and the file is opened in a new image window.

Cancel

Use Cancel button, to close the dialog box without opening a new file.
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Go To Last Folder Visited

Use Go To Last Folder Visited button to move to the last visited folder.
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Up One Level

Use Up One Level button to move up one folder as you navigate.
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New Folder

Use New Folder button to create a new folder.
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View Menu

Use View Menu button is to select the view in the list of the folders and files, the view will be Large Icons, Small Icons, List, Details, or Thumbnails. (This button is only available on Windows 2000 and later versions).

 XE "Save a Captured Image to File Dialog " \* MERGEFORMAT Save a Captured Image to File Dialog

Use the Save a Captured Image to File dialog to specify the save options for a captured image file.

For more general descriptions of supported file formats in the Save a Captured Image to File dialog, refer to Summary of All Supported Image File Formats.

To display the Save a Captured Image to File dialog, from the main menu, choose File -> Save...
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The following are the fields in the Save a Captured Image to File dialog:

Save in

Use Save in dropdown list box to select the drive or folder that you want your file to stored in, when you select drive or folder from the Save in list the content of the selected drive of folder will appear in the list below.

File Name

Use File Name edit box to write name of the file you wish to save with.

Save as type

Use Save of type dropdown list box to select the file format that you wish to save your file with.

Sub Type

Use Sub Type dropdown list box to select the sub-types available for the image format selected in the "Save as type" box. This will often list alternate image compression techniques for a give type of file.

QFactor Drop-down List

Use QFactor dropdown list to select degree of loss in the compression to be used when saving files.

QFactor Edit Box

Use QFactor edit box when you select "Custom" value in the QFactor dropdown list to specify a number that determines the degree of loss in the compression process when saving to an image that uses a lossy compression technique. Valid values are 2 (highest quality) to 255 (lowest file size). This only applies to files saved as LEAD CMP or Wavelet, JPEG, JPEG2000, and TIFF with JPEG compression.

Options

Use Options button to handle more advanced options of the file you wish to save. For example, save multi-page options.

BPP

Use BPP dropdown list box to select the bits per pixel of the file you wish to save with.

Save

Use Save button to, save the file and closes the dialog box.

Cancel

Use Cancel button, to close the dialog box.
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Go To Last Folder Visited

Use Go To Last Folder Visited button to move to the last visited folder.
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Up One Level

Use Up One Level button to move up one folder as you navigate.
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New Folder

Use New Folder button to create a new folder.
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View Menu

Use View Menu button is to select the view in the list of the folders and files, the view will be Large Icons, Small Icons, List, Details, or Thumbnails. (This button is only available on Windows 2000 and later versions).

 XE "Save Images Dialog " \* MERGEFORMAT Save Images Dialog

Use the Save Images dialog to specify the save options for an Image file.

For more general descriptions of supported file formats in the Save Images dialog, refer to Summary of All Supported Image File Formats.

To display the Save Images dialog, right-click an image in the Captured Images Window, then select Save…
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The following are the fields in the Save Images dialog:

Save in

Use Save in dropdown list box to select the drive or folder that you want your file to stored in, when you select drive or folder from the Save in list the content of the selected drive of folder will appear in the list below.

File Name

Use File Name edit box to write name of the file you wish to save with.

Save as type

Use Save of type dropdown list box to select the file format that you wish to save your file with.

Sub Type

Use Sub Type dropdown list box to select the sub-types available for the image format selected in the "Save as type" box. This will often list alternate image compression techniques for a give type of file.

QFactor Drop-down List

Use QFactor dropdown list to select degree of loss in the compression to be used when saving files.

QFactor Edit Box

Use QFactor edit box when you select "Custom" value in the QFactor dropdown list to specify a number that determines the degree of loss in the compression process when saving to an image that uses a lossy compression technique. Valid values are 2 (highest quality) to 255 (lowest file size). This only applies to files saved as LEAD CMP or Wavelet, JPEG, JPEG2000, and TIFF with JPEG compression.

Options

Use Options button to handle more advanced options of the file you wish to save. For example, save multi-page options.

BPP

Use BPP dropdown list box to select the bits per pixel of the file you wish to save with.

Save

Use Save button to, save the file and closes the dialog box.

Cancel

Use Cancel button, to close the dialog box.
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Go To Last Folder Visited

Use Go To Last Folder Visited button to move to the last visited folder.
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Up One Level

Use Up One Level button to move up one folder as you navigate.
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New Folder

Use New Folder button to create a new folder.
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View Menu

Use View Menu button is to select the view in the list of the folders and files, the view will be Large Icons, Small Icons, List, Details, or Thumbnails. (This button is only available on Windows 2000 and later versions).

LEADTOOLS Products and Licensing

 XE "License Agreement " \* MERGEFORMAT LICENSE AGREEMENT - SINGLE-USER PRODUCT

THIS IS A LEGAL AGREEMENT BETWEEN YOU (EITHER AN INDIVIDUAL OR AN ENTITY) AND LEAD TECHNOLOGIES, INC.("LEAD"). BY INSTALLING OR USING THE SOFTWARE, YOU AGREE TO BE BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, REMOVE THE PRODUCT FROM YOUR HARD DRIVE AND PERMANENTLY ERASE ALL COPIES OF THE PRODUCT. IF THE SOFTWARE HAS BEEN DELIVERED TO YOU ON PHYSICAL MEDIA, SUCH AS A CD OR DISKETTE, YOU MUST PROMPTLY RETURN THE SOFTWARE WITH PROOF OF PURCHASE TO THE PLACE WHERE IT WAS PURCHASED FOR A FULL REFUND OF THE AMOUNT PAID. IF THE SOFTWARE YOU HAVE DOWNLOADED IS OFFERED AS "DOWNLOAD ONLY", YOU HAVE BEEN REQUIRED TO ACCEPT THIS LICENSE AGREEMENT PRIOR TO DOWNLOADING THE SOFTWARE. LEAD DOES NOT PROVIDE REFUNDS FOR SOFTWARE OFFERED AS "DOWNLOAD ONLY".

GRANT OF LICENSE.

This License Agreement permits you to use one copy of the accompanying LEAD software program in machine readable binary object code form (the "Software"), which may include electronic documentation, on a single computer/workstation. The Software is "in use" on a computer when it is loaded into the temporary memory (i.e., RAM or Cache) or installed into a permanent memory (e.g., hard disk, CD-ROM drive or other storage device) of that computer. This License does not constitute a sale and does not authorize a sale of the Software or anything created thereby. All intellectual property rights (including copyright, trademark and patent) in the Software are owned by LEAD and its suppliers and licensors, and are protected by the United States laws and international treaty provisions. LEAD and its suppliers and licensors retain all rights not expressly granted herein. You must treat the Software like any other copyrighted material, except that you may make one copy of the Software solely for backup or archival purposes. You may transfer your rights under this Agreement on a permanent basis provided you transfer the license granted by this Agreement, and the Software and all associated printed materials, and you retain no copies, and the recipient agrees to all of the terms of this Agreement.
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You may not use the Software on or over a network or any other transfer device (including the Internet). Use of the Software on more than one computer constitutes copyright infringement and may be punishable by civil fines, criminal penalties, or both.
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You may not rent or lease the Software
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You may not translate, reverse engineer, decompile or dissemble the Software, except to the extent that this restriction is expressly prohibited by applicable law.
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You may not remove any proprietary notices or labels in the Software.
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You may not copy the printed materials accompanying the Software or distribute printed copies of any user documentation provided in electronic format.
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You may not publicly perform or publicly display the Software.

In the event you fail to comply with any of the terms or conditions of this license, your rights to use the Software will end, you shall stop using the Software, remove the Software from your computer and permanently erase all copies of the Software. You may terminate this License at any time by destroying the Software and all copies thereof. You may not export or reexport the Software or any underlying information or technology except in full compliance with all United States and other applicable laws and regulations.

API DOCUMENTATION.

In addition to the executable program code and electronic help file, the Software may contain an application programming interface (API) which enables the user to programmatically control the Software. If the Software contains an API, you are licensed to modify the Software in accordance with the API Documentation and use a copy of the resulting modified Software on a single computer as described in the Grant of License paragraph above. You may not copy (except for your archival purposes) or redistribute the Software or modified Software or any of the API Documentation. If you wish to obtain a license to copy and distribute the Software or modified Software, please contact LEAD’s OEM Licensing department to obtain an OEM license to the Software.

LIMITED WARRANTY.

LEAD and its suppliers and licensors warrant to the original installer of the Software, for a period of thirty (30) days from the date of purchase, that the media on which the Software is distributed is substantially free from defects in materials and workmanship. ANY AND ALL OTHER IMPLIED WARRANTIES WITH RESPECT TO THE SOFTWARE AND THE ACCOMPANYING WRITTEN MATERIALS, INCLUDING, BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGMENT ARE EXPRESSLY DISCLAIMED.

REMEDIES.

Your exclusive remedy shall be, at LEAD’s sole option, (a) the refund of the amount you paid for the Software or (b) repair or replacement of the Software, provided that the defective Software is returned to LEAD (at LEAD Technologies, Inc., 1201 Greenwood Cliff, Suite 400, Charlotte, NC 28204, telephone 704-332-5532) along with proof of the date of purchase within thirty (30) days from the date of purchase. This limited Warranty is void if failure of the Software has resulted from accident, abuse, neglect or misapplication. Any replacement Software will be warranted for thirty (30) days. Except as set forth above, the Software is sold "as is," without any express or implied warranties of any kind.

LIMITATION OF LIABILITIES.

IN NO EVENT WILL LEAD OR ITS SUPPLIERS AND LICENSORS BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, ECONOMIC, COVER, CONSEQUENTIAL, EXEMPLARY OR PUNITIVE DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, USER DOCUMENTATION, OR RELATED TECHNICAL SUPPORT, INCLUDING, WITHOUT LIMITATION, DAMAGES OR COSTS RELATING TO THE LOSS OF PROFITS, BUSINESS, GOODWILL, DATA, TIME OR COMPUTER PROGRAMS, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL LEAD’S AND ITS SUPPLIERS’ AND LICENSORS’ LIABILITY EXCEED THE AMOUNT PAID BY YOU FOR THE SOFTWARE REGARDLESS OF THE FORM OF THE CLAIM (INCLUDING, WITHOUT LIMITATION, ANY CONTRACT, PRODUCT LIABILITY OR TORT CLAIM). BECAUSE SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

U.S. GOVERNMENT RESTRICTED RIGHTS.

The Software and user documentation is provided with RESTRICTED RIGHTS AND LIMITED RIGHTS. Use, duplication, or disclosure by the government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the Commercial Computer Software-Restricted Rights at CFR 52.227-19, as applicable. LEAD Technologies, Inc., 1201 Greenwood Cliff, Suite 400, Charlotte, NC 28204.

MISCELLANEOUS.

No change or modification of the License will be valid unless it is in writing and is signed by LEAD. The provisions of this Agreement are severable; if any provision is held to be invalid or unenforceable, it shall not affect the validity or enforceability of any other provision. If the Software was acquired outside the United States, then local law may apply. Any and all disputes arising hereunder will be heard and settled exclusively in state or federal courts located in the city of Charlotte, County of Mecklenburg, North Carolina, and you hereby submit to the jurisdiction of such courts.

 XE "Products " \* MERGEFORMAT LEADTOOLS Products and Licensing

LEADTOOLS products are ideal for developers involved in still frame, multimedia, document, medical, and vector imaging projects, including Internet/Intranet applications. Independent of the specific application requirement – scanning, file format support/conversion, compression, image processing, annotation, database support, multimedia, etc. – LEADTOOLS provides the most comprehensive, robust, flexible, and powerful imaging solutions available.
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	Double-click this button to launch the Licensing help file and review the license agreements governing the use of LEADTOOLS software.
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	Double-click this button to launch the Products help file and review the full line of LEADTOOLS Products.


Contact Us:

	LEAD Technologies, Inc.
Suite 400
1201 Greenwood Cliff
Charlotte, NC 28204


	Email:

Website:

Phone: 

FAX:

Tech Support: 
	 sales@leadtools.com
 http://www.eprintdriver.com, http://www.leadtools.com
(704) 332-5532

(704) 372-8161

See the Technical Support page.
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